How to disable auto load of applications on restart over OS X Lion?

  • Question

    When I restart my computer I don’t want the apps that were open to relaunch. I’ve disabled “Restore windows when quitting and re-opening app” but that doesn’t help on a restart. How can I do it?

    This isn’t quite an answer, but just double checking:

    enter image description here

    You don’t get the check box that asks you if you want to reopen your windows or not?


    • 1

      Is there a way to make not reopening the windows the default behaviour?

    • 1

      Not with Apple provided functionality. A quick Google does yield this though…

    Another thing you should check is the login items. Go to System Preferences -> Accounts -> choose yours ->login items. Delete those you don’t want to open items.


    • The login items are usually inconsequential compared to OS X Lion’s saved application states because login items are rarer, and usually user set; but still, you have a point.

    • thank im happy with my login items, its the things that aren’t in my login items which were open prior to the restart that are frustrating me. e.g. eclipse launches because I had it open before the restart.

    • Has changed to System Preferences -> Users and Groups -> choose yours -> login items.

    The solution or workaround is quite simple and just included in the system.

    With the Finder, just put a copy of the /System/Library/PreferencePanes/StartupDisk.prefPane (or an alias of it with the name you like) in the dock.

    If you follow me well, you will see that, with this method you can restart your computer in three clicks, exactly the same amount of clicks to restart it from the menu, and one less than you would have to do to restart with disabling “Reopen Windows at Login” by un-checking the option. Even better because if you have several start disks, you don’t need to use anything else to choose the one you want to restart to.

    No need for scripts, commands or queer things, just included in the system.

  • You must be logged in to reply to this topic.